package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(([а-яa-zё0-9]){2})\.((?2){2})\.((?2){3})$`)
var str = `d1.df.dfd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}