#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xis)(?(DEFINE)" & @CRLF & _
" (?<XHTML>" & @CRLF & _
" (?&DOCTYPE)" & @CRLF & _
" \s*" & @CRLF & _
" (?&HTML)" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" # HTML element" & @CRLF & _
" (?<HTML>" & @CRLF & _
" <html(?&attrs)?>(?&content)<\/html>" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" # Match content" & @CRLF & _
" (?<content>" & @CRLF & _
" \s*" & @CRLF & _
" (?:" & @CRLF & _
" ((?&tag) | [^<>]+)\s*" & @CRLF & _
" )*" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" # General tag" & @CRLF & _
" (?<tag>" & @CRLF & _
" <((?&tagname))(?&attrs)?\s*(?:" & @CRLF & _
" \/>|" & @CRLF & _
" >\s*(?&content)\s*" & @CRLF & _
" <\/\g'-1'>" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" # Attributes" & @CRLF & _
" (?<attrs>\s+" & @CRLF & _
" # The name" & @CRLF & _
" (?&keyword) (" & @CRLF & _
" \s*=\s*" & @CRLF & _
" (?:" & @CRLF & _
" (?&keyword)|" & @CRLF & _
" "(?:\\.|.)+?"|" & @CRLF & _
" '(?:\\.|.)+?'" & @CRLF & _
" )" & @CRLF & _
" )?" & @CRLF & _
" (?&attrs)?" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" # Match keyword" & @CRLF & _
" (?<keyword>[^\s\/>"'=]+)" & @CRLF & _
" # Match tag name" & @CRLF & _
" (?<tagname>(?!xml)[A-Za-z_][A-Za-z\d_.-]*)" & @CRLF & _
"" & @CRLF & _
" # DOCTYPE expression" & @CRLF & _
" (?<DOCTYPE>" & @CRLF & _
" <!doctype\s+x?html>" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"(?&XHTML)"
Local $sString = "<!doctype html>" & @CRLF & _
" <html style="''inva'lid css I know">textttt<head></head><body><div class="onfoodstamps"><div class="upper">foo<p>ayyy</p>bar</div>baz</div><br/></head></html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")