using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<XHTML>
(?&DOCTYPE)
\s*
(?&HTML)
)
# HTML element
(?<HTML>
<html(?&attrs)?>(?&content)<\/html>
)
# Match content
(?<content>
\s*
(?:
((?&tag) | [^<>]+)\s*
)*
)
# General tag
(?<tag>
<((?&tagname))(?&attrs)?\s*(?:
\/>|
>\s*(?&content)\s*
<\/\g'-1'>
)
)
# Attributes
(?<attrs>\s+
# The name
(?&keyword) (
\s*=\s*
(?:
(?&keyword)|
""(?:\\.|.)+?""|
'(?:\\.|.)+?'
)
)?
(?&attrs)?
)
# Match keyword
(?<keyword>[^\s\/>""'=]+)
# Match tag name
(?<tagname>(?!xml)[A-Za-z_][A-Za-z\d_.-]*)
# DOCTYPE expression
(?<DOCTYPE>
<!doctype\s+x?html>
)
)
(?&XHTML)";
string input = @"<!doctype html>
<html style=""''inva'lid css I know"">textttt<head></head><body><div class=""onfoodstamps""><div class=""upper"">foo<p>ayyy</p>bar</div>baz</div><br/></head></html>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}