$re = '/(?(DEFINE)
(?<XHTML>
(?&DOCTYPE)
\s*
(?&HTML)
)
# HTML element
(?<HTML>
<html(?&attrs)?>(?&content)<\/html>
)
# Match content
(?<content>
\s*
(?:
((?&tag) | [^<>]+)\s*
)*
)
# General tag
(?<tag>
<((?&tagname))(?&attrs)?\s*(?:
\/>|
>\s*(?&content)\s*
<\/\g\'-1\'>
)
)
# Attributes
(?<attrs>\s+
# The name
(?&keyword) (
\s*=\s*
(?:
(?&keyword)|
"(?:\\\\.|.)+?"|
\'(?:\\\\.|.)+?\'
)
)?
(?&attrs)?
)
# Match keyword
(?<keyword>[^\s\/>"\'=]+)
# Match tag name
(?<tagname>(?!xml)[A-Za-z_][A-Za-z\d_.-]*)
# DOCTYPE expression
(?<DOCTYPE>
<!doctype\s+x?html>
)
)
(?&XHTML)/xis';
$str = '<!doctype html>
<html style="\'\'inva\'lid css I know">textttt<head></head><body><div class="onfoodstamps"><div class="upper">foo<p>ayyy</p>bar</div>baz</div><br/></head></html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);