import re
regex = re.compile(r"""
(?(DEFINE)
(?<XHTML>
(?&DOCTYPE)
\s*
(?&HTML)
)
# HTML element
(?<HTML>
<html(?&attrs)?>(?&content)<\/html>
)
# Match content
(?<content>
\s*
(?:
((?&tag) | [^<>]+)\s*
)*
)
# General tag
(?<tag>
<((?&tagname))(?&attrs)?\s*(?:
\/>|
>\s*(?&content)\s*
<\/\g'-1'>
)
)
# Attributes
(?<attrs>\s+
# The name
(?&keyword) (
\s*=\s*
(?:
(?&keyword)|
"(?:\\.|.)+?"|
'(?:\\.|.)+?'
)
)?
(?&attrs)?
)
# Match keyword
(?<keyword>[^\s\/>"'=]+)
# Match tag name
(?<tagname>(?!xml)[A-Za-z_][A-Za-z\d_.-]*)
# DOCTYPE expression
(?<DOCTYPE>
<!doctype\s+x?html>
)
)
(?&XHTML)
""", flags=re.VERBOSE | re.IGNORECASE | re.DOTALL)
test_str = ("<!doctype html>\n"
" <html style=\"''inva'lid css I know\">textttt<head></head><body><div class=\"onfoodstamps\"><div class=\"upper\">foo<p>ayyy</p>bar</div>baz</div><br/></head></html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")