#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*(\d{3}-\d{6}-\d{2})(?:[^\d]|$)"
Local $sString = "ransferencia exitosa" & @CRLF & _
"Comprobante No. 0000065600" & @CRLF & _
"26 May 2022 - 03:32 p.m." & @CRLF & _
"Producto origen" & @CRLF & _
"Cuenta de Ahorro" & @CRLF & _
"Ahorros" & @CRLF & _
"100-520006-90" & @CRLF & _
"Producto destino" & @CRLF & _
"nameeee nene" & @CRLF & _
"Ahorros / ala" & @CRLF & _
"103-220898-44" & @CRLF & _
"Valor enviado" & @CRLF & _
"$ 1.000.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")