re = /.*(\d{3}-\d{6}-\d{2})(?:[^\d]|$)/
str = 'ransferencia exitosa
Comprobante No. 0000065600
26 May 2022 - 03:32 p.m.
Producto origen
Cuenta de Ahorro
Ahorros
100-520006-90
Producto destino
nameeee nene
Ahorros / ala
103-220898-44
Valor enviado
$ 1.000.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end