import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\d{3}-\\d{6}-\\d{2})(?:[^\\d]|$)";
final String string = "ransferencia exitosa\n"
+ "Comprobante No. 0000065600\n"
+ "26 May 2022 - 03:32 p.m.\n"
+ "Producto origen\n"
+ "Cuenta de Ahorro\n"
+ "Ahorros\n"
+ "100-520006-90\n"
+ "Producto destino\n"
+ "nameeee nene\n"
+ "Ahorros / ala\n"
+ "103-220898-44\n"
+ "Valor enviado\n"
+ "$ 1.000.00";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}