import re
regex = re.compile(r".*(\d{3}-\d{6}-\d{2})(?:[^\d]|$)", flags=re.DOTALL)
test_str = ("ransferencia exitosa\n"
"Comprobante No. 0000065600\n"
"26 May 2022 - 03:32 p.m.\n"
"Producto origen\n"
"Cuenta de Ahorro\n"
"Ahorros\n"
"100-520006-90\n"
"Producto destino\n"
"nameeee nene\n"
"Ahorros / ala\n"
"103-220898-44\n"
"Valor enviado\n"
"$ 1.000.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")