using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([123456789]{9})([ABCD]{1,4})([0]{1,5})([0-9]{1,5})([D]*)$";
string input = @"123456789ABCD00001DDD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}