package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([123456789]{9})([ABCD]{1,4})([0]{1,5})([0-9]{1,5})([D]*)$`)
var str = `123456789ABCD00001DDD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}