$re = '/^([123456789]{9})([ABCD]{1,4})([0]{1,5})([0-9]{1,5})([D]*)$/m';
$str = '123456789ABCD00001DDD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);