using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""taxonomy"":(.*?)\},";
string input = @"""taxonomy"": {""page"":""/products/1/"",""price"":""350.00"",""country_code"":""gb"",""brand"":""apple""},";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}