package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"taxonomy":(.*?)\},`)
var str = `"taxonomy": {"page":"/products/1/","price":"350.00","country_code":"gb","brand":"apple"},`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}