$re = '/"taxonomy":(.*?)\},/';
$str = '"taxonomy": {"page":"/products/1/","price":"350.00","country_code":"gb","brand":"apple"},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);