re = /"taxonomy":(.*?)\},/
str = '"taxonomy": {"page":"/products/1/","price":"350.00","country_code":"gb","brand":"apple"},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end