#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?s).*Subject:(?<identificationValue>ST[0-9]*)\.\d*\.\d*\.(?<identifier>[0-9]*).*Text: (?<remark>.*)Code:.*$"
Local $sString = "From:stoerungen@fe-trading.at" & @CRLF & _
"Subject:ST412.3.3.28 [RCT/28]: Kartenleserfehler, bitte pruefen!" & @CRLF & _
"Send date:Mon May 08 13:28:51 CET 2017" & @CRLF & _
"Content type:text/plain; charset="iso-8859-1"" & @CRLF & _
"" & @CRLF & _
"System: RCT/FAULT (08.05.2017 13:28:51)" & @CRLF & _
"Station: ST412, 4846 Redlham, Gewerbepark Ost 27" & @CRLF & _
"Text: Kartenleserfehler, bitte pruefen!" & @CRLF & _
"Gruppe: 3" & @CRLF & _
"Device: 3" & @CRLF & _
"Code: 28"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")