using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[^\?]*/)?[^\?/.]+)($|\?.*)";
string substitution = @"$1/index.html$2";
string input = @"myawesomecategory/azure/mypost?query=string";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}