// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)((?:[^\?]*/)?[^\?/.]+)($|\?.*)").unwrap();
let string = "myawesomecategory/azure/mypost?query=string";
let substitution = "$1/index.html$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}