use strict;
my $str = 'myawesomecategory/azure/mypost?query=string';
my $regex = qr/((?:[^\?]*/)?[^\?/.]+)($|\?.*)/isp;
my $subst = '$1/index.html$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";