import Foundation
let pattern = #"((?:[^\?]*/)?[^\?/.]+)($|\?.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"myawesomecategory/azure/mypost?query=string"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/index.html$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}