#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S)"
Local $sString = "this is line one" & @CRLF & _
"this is line two" & @CRLF & _
"this is line three" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")