$re = '/(?s)(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S)/';
$str = 'this is line one
this is line two
this is line three
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);