import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S).*?(?<!\\S)([A-Za-z0-9\\.]+)(?!\\S)";
final String string = "this is line one\n"
+ "this is line two\n"
+ "this is line three\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}