re = /(?s)(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S).*?(?<!\S)([A-Za-z0-9\.]+)(?!\S)/
str = 'this is line one
this is line two
this is line three
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end