import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]-(?=[A-Z]))|([A-Z](?=[0-9])|[0-9](?=[A-Z]))";
final String string = "A-BA -> ABA\n"
+ "A-B-BAB -> ABBAB\n\n"
+ "9AHYA7 -> 9-AHYA-7; \n"
+ "977AB99T5 -> 977-AB-99-T-5\n\n\n"
+ "HS98743YVJUHGF78BF8HH3JHFC83438VUN5498FCNG\n"
+ "7267-VHSBVH8737HHC8C-HYHFWYFHH-7Y84743YR8437G";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}