$re = '/([A-Z]-(?=[A-Z]))|([A-Z](?=[0-9])|[0-9](?=[A-Z]))/m';
$str = 'A-BA -> ABA
A-B-BAB -> ABBAB
9AHYA7 -> 9-AHYA-7;
977AB99T5 -> 977-AB-99-T-5
HS98743YVJUHGF78BF8HH3JHFC83438VUN5498FCNG
7267-VHSBVH8737HHC8C-HYHFWYFHH-7Y84743YR8437G';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);