import re
regex = re.compile(r"([A-Z]-(?=[A-Z]))|([A-Z](?=[0-9])|[0-9](?=[A-Z]))", flags=re.MULTILINE)
test_str = ("A-BA -> ABA\n"
"A-B-BAB -> ABBAB\n\n"
"9AHYA7 -> 9-AHYA-7; \n"
"977AB99T5 -> 977-AB-99-T-5\n\n\n"
"HS98743YVJUHGF78BF8HH3JHFC83438VUN5498FCNG\n"
"7267-VHSBVH8737HHC8C-HYHFWYFHH-7Y84743YR8437G")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")