import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\. *(?=\\w+)|,[\\s\\w]*$";
final String string = "Dr. Ian Smith\n"
+ "Prof. Dr. Ian Smith\n"
+ "Ian Smith, Phd, Dr\n"
+ "Dr. Ian S.\n"
+ "Ian S.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}