$re = '/\w+\. *(?=\w+)|,[\s\w]*$/m';
$str = 'Dr. Ian Smith
Prof. Dr. Ian Smith
Ian Smith, Phd, Dr
Dr. Ian S.
Ian S.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;