import re
regex = re.compile(r"\w+\. *(?=\w+)|,[\s\w]*$", flags=re.MULTILINE)
test_str = ("Dr. Ian Smith\n"
"Prof. Dr. Ian Smith\n"
"Ian Smith, Phd, Dr\n"
"Dr. Ian S.\n"
"Ian S.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)