re = /\w+\. *(?=\w+)|,[\s\w]*$/m
str = 'Dr. Ian Smith
Prof. Dr. Ian Smith
Ian Smith, Phd, Dr
Dr. Ian S.
Ian S.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result