#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\w*])(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])"
Local $sString = "Well f*** you!" & @CRLF & _
"Well f***!" & @CRLF & _
"f***" & @CRLF & _
"f*** this!" & @CRLF & _
"secret code is 123f***" & @CRLF & _
"f**k this!" & @CRLF & _
"" & @CRLF & _
"sh*t* not?" & @CRLF & _
"sh*t but this" & @CRLF & _
"f***a this not?" & @CRLF & _
"f***! but this" & @CRLF & _
"f**** this not?" & @CRLF & _
"" & @CRLF & _
"ab sh*t" & @CRLF & _
"ssh*t" & @CRLF & _
"*sh*t"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")