import Foundation
let pattern = #"(?<![\w*])(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Well f*** you!
Well f***!
f***
f*** this!
secret code is 123f***
f**k this!
sh*t* not?
sh*t but this
f***a this not?
f***! but this
f**** this not?
ab sh*t
ssh*t
*sh*t
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)