const regex = /(?<![\w*])(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\w*])(?:sh\\*t|sh\\*\\*|f\\*\\*k|f\\*\\*\\*)(?![\\w*])', 'gm')
const str = `Well f*** you!
Well f***!
f***
f*** this!
secret code is 123f***
f**k this!
sh*t* not?
sh*t but this
f***a this not?
f***! but this
f**** this not?
ab sh*t
ssh*t
*sh*t`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}