import re
regex = re.compile(r"(?<![\w*])(?:sh\*t|sh\*\*|f\*\*k|f\*\*\*)(?![\w*])", flags=re.MULTILINE)
test_str = ("Well f*** you!\n"
"Well f***!\n"
"f***\n"
"f*** this!\n"
"secret code is 123f***\n"
"f**k this!\n\n"
"sh*t* not?\n"
"sh*t but this\n"
"f***a this not?\n"
"f***! but this\n"
"f**** this not?\n\n"
"ab sh*t\n"
"ssh*t\n"
"*sh*t")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")