using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bbcl-2\b(?:(?!\bbcl-\d|\bnot\b).)*?\bdetected\b";
string input = @"bcl-2 was detected in 45% bcl-6 was not detected
bcl-2 was not detected bcl-6 was detected in 45%
no evidendce of bcl-2 bcl-6 was detected in 45%";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}