$re = '/\bbcl-2\b(?:(?!\bbcl-\d|\bnot\b).)*?\bdetected\b/';
$str = 'bcl-2 was detected in 45% bcl-6 was not detected
bcl-2 was not detected bcl-6 was detected in 45%
no evidendce of bcl-2 bcl-6 was detected in 45%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);