import Foundation
let pattern = #"\bbcl-2\b(?:(?!\bbcl-\d|\bnot\b).)*?\bdetected\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bcl-2 was detected in 45% bcl-6 was not detected
bcl-2 was not detected bcl-6 was detected in 45%
no evidendce of bcl-2 bcl-6 was detected in 45%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)