#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\d-]{0,3}-\d)(?=[\d-]{5})[A-Z\d-]+$"
Local $sString = "12345ABC" & @CRLF & _
"12345123" & @CRLF & _
"1234-1" & @CRLF & _
"1234--1" & @CRLF & _
"1----1AB" & @CRLF & _
"123----" & @CRLF & _
"-----" & @CRLF & _
"" & @CRLF & _
"123A----" & @CRLF & _
"-2-2-" & @CRLF & _
"1AAAAAA" & @CRLF & _
"1-2-3-A" & @CRLF & _
"----1AB" & @CRLF & _
"--1--1A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")