use strict;
my $str = '12345ABC
12345123
1234-1
1234--1
1----1AB
123----
-----
123A----
-2-2-
1AAAAAA
1-2-3-A
----1AB
--1--1A
';
my $regex = qr/^(?![\d-]{0,3}-\d)(?=[\d-]{5})[A-Z\d-]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}