using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![\d-]{0,3}-\d)(?=[\d-]{5})[A-Z\d-]+$";
string input = @"12345ABC
12345123
1234-1
1234--1
1----1AB
123----
-----
123A----
-2-2-
1AAAAAA
1-2-3-A
----1AB
--1--1A
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}