$re = '/^(?![\d-]{0,3}-\d)(?=[\d-]{5})[A-Z\d-]+$/m';
$str = '12345ABC
12345123
1234-1
1234--1
1----1AB
123----
-----
123A----
-2-2-
1AAAAAA
1-2-3-A
----1AB
--1--1A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);