# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Select +(.+);/switch ($1)\{/gm;t' <<< " Select ob.name;"