re = /Select +(.+);/m
str = ' Select ob.name;'
subst = 'switch ($1)\\{'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result