import Foundation
let pattern = #"Select +(.+);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" Select ob.name;"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"switch ($1)\{"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)