#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/support/(?!.*software_updates).*$"
Local $sString = "/support/software_updates/" & @CRLF & _
"/support/foo/software_updates/" & @CRLF & _
"/support/software_updates/foo/" & @CRLF & _
"" & @CRLF & _
"/support/foo/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")