$re = '~^/support/(?!.*software_updates).*$~m';
$str = '/support/software_updates/
/support/foo/software_updates/
/support/software_updates/foo/
/support/foo/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);