re = /^\/support\/(?!.*software_updates).*$/m
str = '/support/software_updates/
/support/foo/software_updates/
/support/software_updates/foo/
/support/foo/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end