using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/support/(?!.*software_updates).*$";
string input = @"/support/software_updates/
/support/foo/software_updates/
/support/software_updates/foo/
/support/foo/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}